Kitsu (server error)

Hi, I’m trying to sync Kitsu to Ayon server.

For testing purposes, I am using the Kitsu Docker. I’m able to connect to Kitsu via the Ayon Launcher and a small test .py using gazu.

However, following this guide to set up ayon-kitsu, after the service is running, nothing shows up in the Kitsu tab.

I am getting two errors:
Could not login to Kitsu (server error)
[GET] /addons/kitsu/1.0.1/pairing: UNHANDLED EXCEPTION

Is there any where else to look for problems? I have done a fresh install of both and tried to use our production Kitsu, but no luck.

Ayon server: 1.0.0
Kitsu Addon: 1.0.1

Thanks!

Hello,
I couldn’t reproduce the same error :sweat_smile:
Here’s my setup:

  1. Ayon server: 1.0.0+202401162208
  2. Kitsu Addon: 1.0.1
  3. Kitsu Service: 1.0.1
  4. I have my username and password added to secrets
  5. They only caveat that I need to set my kitsu addon settings again as they don’t inherit from the old one when updating the addon version.

I also created a new production, clicked pair and sync. it works fine.

Hey, thanks for taking the time to respond. I got it working as expected when I disabled Kitsu’s 2fa. Has anyone else had issues with this?