Ayon nuke publish shotgrid login error

Hi Ynput team

We continue our journey to test Ayon features and this case if for shotgrid addon integration.
We are using the following versions.
Shotgrid sync: 0.2.8
Ayon server: 0.5.4+2310271400
Ayon client: 3.17.0

So far we are able to see / list the projects from shotgrid under “Shotgrid Sync” tab and syncronize Shotgrid —> Ayon, so kind of working in that direction, even if I creates a task in shotgrid it automatically mirrors into Ayon, nice!.

Now I tried to publish from nuke and got the following error, if I understand correctly I should see an option in Ayon tray named “Shotgrid” but I see nothing, what am I missing here?

the above to try/test “Ayon—>Shotgrid” automatic sync.

Just wonder if I need to add the services here somehow?!

I am missing the “Host”

Just mentioning this as the docs point to that.

Hi @BigRoy @mustafa_jafar, do you have any comment about the above error?

I’m not familiar with SG addon. all what I can do is guessing.
we can tell you have set up Shotgrid and Ayon server and you have SG addon enabled.
but, I don’t why the tray button doesn’t show up.

if I were you, I would double check installation steps making sure I didn’t mess up with something.

I would also try sneaking around and checking what will happen if I
set some environment variables manually in the current opened DCC session

os.environ["AYON_SG_USERNAME"] = "you sg user name"

by the way the error in your screenshot was raised by these lines

this is ASH (Ayon Service Host), maybe your publish was failing because these services don’t exist (I’m just guessing)
anyway, the simplest way to set up an ASH is mentioned in this guide. then you’ll be able to add the necessary three services that mentioned by the docs.

Thank you for the feedback @mustafa_jafar
Yes the services are running, but we will try the ASH setup.

Who do you think from your Ynput team is familiar with SG addon and can help us with this issues?
The setup (SG addon) kind of works from SG → Ayon but not the other way around, and I am guessing the above error is part of the symptoms.

Still the questions why the “Shotgrid” option does not shows up in ayon tray, we are using Ayon client 3.17.0 shown in the image above.
So you know if there is a known issue with that version or is it a recommended version for the server version 0.5.4?
Again thank you for your feedback and help.

Hi @Brno

I’ve been using the ShotGrid sync service for some time now, it’s very much (as with the rest of AYON) in testing right now and whilst it functionally works there’s been little time to work on the documentation as development happens.

I also wanted to confirm that the SG sync service is bi-directional and by choice.
You can have ShotGrid push to AYON one way, or vice versa or bi-directional - additionally you can have that be automatic or manual pushing/pulling.
Right now the sync is only for Scenes/Sequences/Shots/Tasks and Versions (only versions published from AYON go to SG, not vice versa).
In the future it will also sync fields/attributes in ShotGrid i.e. cut information.

Let’s diagnose some things first if possible.

  1. Do you have the ShotGrid add-on enabled in your Production tagged bundle?
More details

Ignore the version, 0.2.8 is fine for now, I’m testing bleeding edge updates with the developer hence the 0.2.9 version.

  1. In Studio Settings, do you see a ShotGrid Sync tab at the top and when you hit populate do you see a list of your projects?

In theory, to have the ShotGrid button appear on the AYON tray tool you only need to have the add-on enabled in the bundle.
For it to actually function, you also need the ASH Worker running with your ShotGrid services running within that; but the button should appear without that step.

I suspect potentially you don’t have ShotGrid credentials set up in the add-on settings like I have here:


For the ShotGrid services (processor, transmitter, leecher) it sounds like you have manually run them using the instructions on the GitHub page. This is fine and it works normally but I would highly recommend you stop those, remove them and run/launch the services through ASH.

This is done by spawning them on the Services page you showed a screenshot of here:

Your post

However, as you saw you didn’t have a “Host” to choose from, that’s because you’re not running an ASH ‘Worker’ that is connected to your AYON instance.

The easiest way to run this is by adding the docker service in this compose file to your AYON docker compose file:

You will need to make sure you change the change the “http://server:5000” to whatever IP address or DNS name you have your AYON server running on & the port.

Additionally, for now you shouldn’t need to change the AYON API KEY “veryinsecurapikey” as that will connect to the “service” user that you will see by going to “Users” in AYON.
I recommend though that you eventually delete that key on the service user and generate a new one:


Once you have that Worker running, go back to Services in AYON and spawn a leecher, processor and transmitter.

For good measure, I would also log out of AYON in the tray tool, relaunch it and re-login.

Hi @matteo, appreciate your feedback.

  • Shotgrid Addon is anabled
  • We can see the project list under Shotgrid Sync tab.
  • We do have the credentials for shotgrid set up but in server version 0.5.4 +2310271400 something changed and I see this instead

and I need to add the “Shotgrif Script Name” and “Shotgrid API Key” through the “Secrets” tab.

So, we ran the services an ASH for the services now.

After all this, I closed and re-launched the Ayon client (launcher) and I can not see a “Shotgrid” option, are the versions conflicting somehow?. which versions should I try?

for sure I am missing something, again appreciate your help/ time.

Let me know if you need to see something specific or you want me to run something at my end.

Hmm very strange, all seems to be correct on the server side then especially if the worker can see the services are “running”.

Okay 2 things:

  1. On the tray tool, can you go to Admin > Console.
    Do you see the ShotGridAddon loaded there like this?

  2. Are you running AYON from source or from a downloaded launcher installer .exe?
    I’m running BETA6 but the add-on has been showing for me for months so I’m unsure the version is the issue, client version for me is 3.17.4.

Hi @matteo

  1. Here is the addon.

  2. We are running Ayon from a downloaded exe file, Last version we built it from source files, we are using windows.
    for us is Beta5, ( 3.17.0) I guess we should try Beta6, or Beta7?!

Hi @Brno

Did you manage to get it working with a simple update? I would be surprised if you did.

To be honest I really can’t see what the issue is from here, everything seems to be in place on the server side and on the tray tool side in as much that it loads the add-on clearly.

At this point we might need @Minkiu to weigh in, honestly getting the ShotGrid button to appear wasn’t even a thought for me it just worked so there’s something a bit awry here

Hi @matteo
I am still waiting on IT to install the update once installed I will feedback here.
(we are going to try Beta6) same you have.

Thank for adding Minkiu it is always useful having another pair of eyes into this, but first I will test with the update and feedback.
thank you

1 Like

I tried the ayon_console.exe instead and this gives me additional information and indeed this error explains why the shotgrid option does not shows up.

Any advice is welcome, maybe the versions?

Hi @matteo
Found the issue, there is a json file that stores the credentials (user/AppData/Local/pypeclub/openpype/openpype_settings.json) which had incomplete credentials (maybe need a better error handling here).

Now that I got the “Shotgrid” option for login, it says “Can’t authenticate user” just wonder if there is something to do with 2-factor authentication and how this is handle in Ayon.


Hey @Brno

Good to know about the hidden JSON file, honestly that still surprises me that a reinstall didn’t wipe that.

For the creds, at least from my usage, you have to go into ShotGrid > Top Right Menu > Account Settings > Legacy Login and then set a new passphrase.

The issue is that the add-on uses the normal ShotGrid API to login instead of going through Autodesk’s SSO platform, so we need to set a legacy password which isn’t tied to your AD account.

Hi @matteo
I will try the “Legacy Login” I can see right now it says “Passphrase is missing”, so I will give it a go.

What would be the implications to use this “Legacy Login” instead of the 2FA we are all using?, any security concerns?. I am kind of hearing right now IT saying “that is insecure!” or anything like it :P.

Thank you Matteo.

No worries, so yeah ultimately this could be seen as a vector for attack as it bypasses AD 2FA entirely.

That being said, this legacy username/pass is not used for normal browser-based login and just for API access so someone would need to go that route.

At our studio we mitigate this through IP whitelisting, so only our office and datacentre can access our SG instance; though I know that’s not ideal for some setups.

Hi @matteo
I have just tried but just realized that our shotgrid site settings enforce the use of 2FA, and as expected IT does not want to turn that off. :slight_smile:

I guess we will be defining our next steps as shotgrid is central to our studio.

Appreciate your help, if you have any thought I would love to hear from you.


Ah okay, yeah the lack of 2FA without something like IP whitelisting can be a sore topic for sure.

In terms of SSO support, which is what would be needed for Autodesk, there is some discussion in this thread but I’m not sure where it’s going and how it would be accomplished.