Yeticache error in 3.18.7

Hello Team,

I am experiencing an error while attempting to publish yeticache in op3.18.7. However, I am able to successfully publish the same file in op 3.16.6, Please check the screenshot

Thank you

Hi @Raj,

Interesting issue. Your screenshots show no Extract Yeti Cache plug-in, so basically no ‘export’ or ‘extraction’ is being triggered.

In the publisher in “Details” there’s a “Crashed Plugins” right hand side. I have a feeling that it might be failing somewhere there and it appears in that list.

  • Is it listed there?
  • If so, can you share the error it gives here?

Also, the publisher UI has an “Export report” button which exports a JSON log of your publish - which will make it easier to debug for others. So if you can provide that too, that would be great.

Hi @BigRoy ,

Thanks for your quick response, i have attached the screenshot and the report log

and i tried publishing Unreal yeti cache export , worked for me in op 3.18.7.

Thanks @Raj if you click the bottom left icon you can “Export to file” the report of your publish. It allows for debugging purposes to load that file on e.g. my machine to get the same publisher UI state you had - which eases debugging.

Could you still share that?

Anyway, it not being a crashed plug-in makes it seem like for whatever reason it doesn’t trigger the plug-in.

1 Like

@BigRoy , json log file

Thanks.

I’m pretty sure the issue is due to this:

Plug-in class names should be unique.
I mentioned that issue on Discord a while back but it seems even in latest develop that issue still exists.

Created a Pull Request with a fix just now: Maya: Ensure unique class name compared to `extract_yeti_cache.py` by BigRoy · Pull Request #6251 · ynput/OpenPype · GitHub

And an equivalent one for AYON: Maya: Ensure unique class name compared to `extract_yeti_cache.py` by BigRoy · Pull Request #251 · ynput/ayon-core · GitHub

1 Like

works for me now thanks @BigRoy