Troubleshooting Errors in Resolve

Trying conform from resolve and getting this error

To solve this we need to use older opentimelineio

python -m pip install OpenTimelineIO==0.15.0

@BigRoy i
but even with correct version i fave integration issue

and i found that it collects wrong frame range from resolve.

If i try to load plate to nuke (i see new version even with error) and has no color space selected whitch i provided in resolve and has wrong framerange whitch later leads to errors from publishing from nuke because of out of frame range error

resolve exports one frame less than nedeed

1 Like

Thanks - did a test run here and was able to reproduce the error and implement a simple fix.

I haven’t delved into that frame mismatch. I might try and reproduce that later and report it.

I managed to run hiero and have no errors on publishing but same thing one frame more in database so nuke will not render shot because same error

two screens one from loader

and one loaded from explorer

and if i publish with hiero\davinci having 0 frame handles it has same error

seems like its not a problem with loader or database. seems like edit app makes platefile one frame shorter

on the screen you can see last avalible frame in nuke on the left and this frame in hiero and one frame left unpublised in hiero

And one more thing: i’d like my published shots to be published in kitsu too but i dont see any kitsu review stage in publishing procces only kitsu logout is it possible?

Ah - I’ve had that before with certain codecs/encodings - however, that was always only the case in Adobe applications. Anyway, are you saying that thus the issue is NOT in AYON itself for the missing frame?

Do you have Color Management enabled in settings?



Without that it’s quite possible there’s no OCIO data being collected at all. However, even with that enabled I’m not sure if any OCIO from Resolve is being ingested along with the publish.

color i’ve already solved)

idk what exacley wrong because its just one frame in the end and where exactly the probles is i cant know

1 Like

@BigRoy maybe its because this change? for resolve i’ve installed pyside2 but new server and launcher using 6

Sorry, which issue is because of that? The frame mismatch? That seems unlikely since the Qt change is just a UI change - shouldn’t affect the load/publish logic.

so is there a workaround for it?

@BigRoy accurding to publish status from hireo its opentimelineio makes frame missmatch, do we need to make some code debug ourself?

i believe that’s what causing problems

1 Like

Hello @timsergeeff,
As far as I know, make code debug as much as you want to be able to figure out the problem.
Adding any comments on the GH issue to confirm the bug on your side would be much appreciated.

would you mind adding a TL;DR in your post about issues you encountered so far ?

  • OpenTimelineIO Error
  • Frames miss match

actualy i domt know what causing the problem(

i dont get what you want me to do… edit first massage in topic?

Found strange thing with mp4 source it works ok! prores only gives missmatch

i digged dipper inside degub and found that all pre ffmpeg steps are correct and data is valid and inside ffmpeg one frame is already missing

1 Like

Sweet. I just replied to your ayon-resolve reported issue that I was unable to reproduce.

If I understand you correctly now you’re facing what seems like an FFMPEG bug on the Prores file you’re using? Were you able to reproduce this with just FFMPEG without AYON involved?

1 Like

If you tell me how- i’try) i just was digging logs and was seeing 991-1020 frames and inside just next step in ffmpeg 1-29 frames whitch forced me to google dedicated errors with ffmped and i found something but nothing useful and i just tried mp4 at 23.987 fps in the same timeline and punlished it and it has 30 frames! Wonder whats wrong with mow prores because this is just standart davinci export from colorist at 25 fps ( timeline is 25 too)

Where is the best place to discus here or on git?