Setting up AYON launcher on linux mint & Ubuntu

I succesfully set up the AYON server (so far) but have been running into setting up the launcher.
The launcher as a binary crashes when I run the executable.

As a result, I want to build it. However I run into the issue of getting access to qt6-default. running sudo apt install qt6-default gives me the error that the package cannot be found.

The documentation mentions qt6-default in the commands but refers to qt5 in the text.

I also cannot seem to find qt6-default in the Ubuntu packages in any of the past releases.

What would be the correct approach on how to solve this? Is the documentation out of date? Or is it an issue on the Distro itself?

Hi @HannahFantasia - nice to see you here.

First off, Qt5 → Qt6 has been a recent update so any out of date mentions were just missed and may not have been correctly updated for all Linux distributions.

The launcher as a binary crashes when I run the executable.

Interesting, is there any sort of log output or stack trace you get before that occurs? Is there any trace of how far it does get to launch the executable?

Also, what’s your Ubuntu version?

Unfortunately my Linux experience with AYON is basically non-existent so maybe someone else who’s ever tried it may be able to provide more details. Maybe @mustafa_jafar ?

hello there.
i didn’t try the default Linux launcher yet but compiling (RHEL9) always worked quite well.
here are some links regarding library`s that you might need to use

apparently qt5-default was set up in an interesting way on Ubunto a while ago and so the combination package is not that available, but you should be able to build the parts yourself (in the end -default is just a combination off other packages)
here`s a link to the qt5 version (apt - qt5-default not in Ubuntu 21.04 - Ask Ubuntu) but the same applies for qt6
i assume that qtbase5-dev is now qt6-base-dev (this also includes “qt6-qmake” ← this dost really exist any more but it was separate in qt5)
and then you have this:
what replaces the qtbase5-dev-tools in qt6

hope that enough if not let us know.

Happy to see you here too.
I run Linux Mint so it’s similar to Ubuntu 22.04 on most dependencies.

I solved the qt part by doing a fresher start and installing the packages based on @Lyon-Rosenblatt-Ynpu 's feedback

1 Like

Great - does that mean you were able to solve all the issues mentioned in this topic?

Note that you can mark @Lyon-Rosenblatt-Ynpu 's answer as the solution.

regarding setting up the QT stuff yes, now onto the distutils frenzies.