Maya Rig: Custom Nodes not published along

Hello there ! I’m having an issue with a rig publish. I use for facial capture the MocapX plugin wich use two objects visible in the outliner of Maya. The problem is that I cant parent them or group them. So, in the end, they aren’t inside the main group for the publish and I end up with no MocapX component at all in my hero file…

We tried to tag them creating a mayascene before the publish but it hasn’t worked…

Do you think someone can help me on this ? thank you ! :slight_smile:


here are the three components :slightly_smiling_face:

They should be published along if you add these into the rigMain object set.

I believe since they are Maya nodes you should be able to add them there even though they are not DAG (hierarchical) maya nodes.

Also, I’m pretty sure those rigMain_controls_SET and rigMain_out_SET should be inside rigMain for the publish to work. But maybe you have “Display > Show set members” disabled in the maya outliner?

1 Like

Great ! Thank you for your help ! You are right !