Error building ayon launcher main branch

After following the Windows build instructions I run into an error ./tools/manage.ps1 create-env

>>> Installing virtual environment from lock.
Creating virtualenv ayon in C:\Users\bootsch\repos\third-party\ayon-launcher\.venv

module 'virtualenv.create.via_global_ref.builtin.cpython.mac_os' has no attribute 'CPython2macOsArmFramework'
!!! Poetry command failed.

Any idea what I might be missing?


I couldn’t replicate your error,

Here are what I have done:

I don’t like to use C drive.
So, I cloned the repo to another drive

git clone --recurse-submodules

Then in windows powershell

./tools/manage.ps1 create-env

Thanks for the feedback. Just for details, are you on Win10 or 11?
Will try again in a clean virtual machine.

Must be something in my environment. Build on clean Win10 virtual machine worked as expected.

win 10

Good to hear :clap:

That’s great. It might still be nice to debug why your machine itself would fail. First off:

Also, this hints at it potentially being a virtualenv version clash. And this issue hints at the fact that you might have a ‘broken virtualenv’ install.

If that doesn’t help, then we can look into:

  • What’s the exact Python version you’re using on both machines? (does the patch version match?)
  • Maybe compare system and user PATH and PYTHONPATH environment variables to see if there’s something that stands out as a difference between the two.

Thanks for the great pointer.

I recently installed pyenv 3.1.1 but it turns out also virtualenv 20.23.0 in a ‘manual’ installed python 3.9.15 version.

I uninstalled virtualenv 20.23.0 and now can successfully build ayon-launcher!

Windows 11 Pro
Python 3.9.12 installed with pyenv.

So it was indeed some clash between pyenv and the pip installed virtualenv.


1 Like