AYON monthly beginner’s topic - June‘24

Today i’ve recorded a video for yours better understanding

Im speeding up a lot not to waist yout time hope it will show all the problems i have exactley as i see them!

for me now i just need comfortable way to publish plates to ayon for artists to start working with metada i provided (pulled up from file). Noone will do it manualy, for me this is the only thing stopping me for further develoging ayon in my producion.

1 Like

@timsergeeff Just want to say this is excellent, and thank you very much for providing the screen capture - and sticking around to try and solve this.

But, boy - this is a lot! :smiley:

Kitsu integration

What syncs which way, I’m not the one to confirm - sorry. No knowledge on my end.

You seem to have an issue with how it syncs Frame Start, Frame End and Frames(?). I’m not sure what Frames means in Kitsu. But that issue in the video at +/-20 seconds into the video is maybe better answered by @Danell or maybe @frankrousseau can explain a little about the Kitsu-side of things (although likely knows little about the AYON integration?)


You seem to have looked into it and figured out how stuff should work, great! Unfortunately the opentimelineio library issues are holding you back.

So, I decided to give this a go myself - and I unfortunately did not get the same error:

Which makes me think that maybe - since you’ve likely installed opentimelineio just now that you may be on a recent version that may have changes to their API breaking the code?

Using pip list for my python, e.g. python -m pip list I found out that I’m on OpenTimelineIO version 0.15.0

So I upgraded my version using python -m pip install --upgrade OpenTimelineIO and it installed version 0.17.0. And suddenly the Resolve integration didn’t even start. I tried just running the standalone Python and do import opentimelineio. Also crashed!? (This may not occur to you - it may just be issues in my Python env)

So, I uninstalled 0.17.0 and installed 0.16.0 instead using:

python -m pip uninstall OpenTimelineIO
python -m pip install OpenTimelineIO==0.16.0

Now the import opentimelineio didn’t crash the Python interpreter. This also fixed the integration.

And indeed - I’m getting the same error as you:

So yes, there seem to be some OpenTimelineIO issues with recent versions - reported the ayon-resolve bug here.
For now I’d recommend downgrading your OpenTimelineIO package to 0.15.0:
Which would be along the lines of this

python -m pip uninstall OpenTimelineIO
python -m pip install OpenTimelineIO==0.15.0

Or however you’re managing your python environment.


For Hiero, I’m personally clueless. I’ve never used the software. All the logic in the integration appears to be in-place.

  1. Through this code the HIERO_PLUGIN_PATH environment variable should be set to include the relevant AYON startup scripts folder to trigger in the Hiero integration. According to this Hiero docs that should work fine.

So, to debug - it would be good in Hiero if you could check whether the environment variable is set as intended. If you can run some Python code there:

import os

That should print the paths - and it should include a path to the ayon_hiero/api/startup addon.

Whether that does or does not exist - you could try and trigger the host install manually that is in this file. Which means just running this Python code in Hiero:

from ayon_core.pipeline import install_host
import ayon_hiero.api

That file also does some odd try..except and it’s a bit unclear WHY it does that.
But you may need to also call:

import ayon_hiero.api.lib

To complete that.

I suspect that if there are errors - they will start showing up when running any of this in the Python console of Hiero (assuming it has one)

So, what was your HIERO_PLUGIN_PATH printed output? And what did these install logic show as errors? (If they do show errors, then it seems that Hiero doesn’t show errors on startup scripts - which explains why it was making it hard to debug!)


This got me so confused - until I played the video at 0.5x speed. It seems that JUST before you publish you are removing the top video file in the “representations” field. The representation file there is required, and hence the error you are getting is correct.

The review file is optional. I’m personally not entirely sure what the review field is for and what that does to differ the result. I believe that may affect whether it’d end up on Kitsu or not. Regarding the reviewable maybe @libor.batek knows more and regarding what ends up on Kitsu maybe community member @Danell knows a bit about the outputs?


Not being a Nuke user myself I’m not sure what is wrong with that first loaded clip. You mentioned something about “frame range”, “resolution” and “handles”. What was wrong in your opinion?

And good to say at least that ended with a YAY! :tada:
Nuke got at least one plate to Kitsu.

Have you tried Editorial Package?

So, have you also tried the Editorial Package in the Tray Publisher. It sounds somewhat close to what could work for you - and I’m sure @milan can tell you more about it.

Not sure how possible it is, but we might want to take some of this conversation into a dedicated clearly labeled topic of its own @mustafa_jafar ?


this is totaly okey! I mean that framerange of a workfile was set manualy by hand and for big quantites of shots i find this to be unndessesary difficult. Thats why i need some way to automate this things to not put numbers like resolution wich is always eqals sourse resolution and framerange. Thats why- i need resolve if it works like i imagine)) (or like in tuts)

this is fine beccause its more convenient to set it on ayon this was just a demonstration of a bug(?) i found.

This solves this issue!!! but i have another one)))) wjen trying to publish plate to kitsu created shot

but some progress was made!!! because if i use standart hierarhy and not trying to push plates to kistu maded shots ayon creates NEW shot and plases video here of couse with errors ahaha

and now i can open nuke wotkfile dutation and resolution was set automaticaly hooray! and i see my plate but untunately workfile has no handles in this example it was 50 frames on each end ( not the end of a world, i assume if we solve some issues it will do it)

I dont mind using hiero, for me resolve is better so feels like we are almost done here)

Traypublisher works okey, this was just my expirements on like what’s gonna hanned ahah but as i see traypublisher laks of feature to publish plates with metadata like we do in resolve but i feel like it’ll be a great feture because is’s so simple to just open publisher and tell it: this file to this shot use original res and dutation have 12franes handles! Maybe you should think about adding it or telling me how to do it))) because it’s simplifies MAINplates delivery in a lot of scenarios. Why i need always to open resolve when i can just put a file and tell that all files properties should be provided to workfile))

I’m not because i find if unlogical because anyway i need to open resolve to export edl or xml if it was not provided from client. So why i need to use it? Even if i have xml\edl i find i easier to open resolve to inspect whats inside and maybe comsomize some publish settings

we can beat it! thanks)

Nice to hear you’re making progress - you’re raising some other good questions and points. It would be very nice if you’d be ok in separating those into “separate” reports (like a separate community topic) just so that a person who maybe more knowledgeable in a certain area doesn’t need the full context of this quite lengthy report of different things.

The way I understand the remaining “issues” are:

  • Kitsu sync bug report on the shot frame lengths with frames not syncing correct to AYON.

  • Resolve: When trying to publish Plate to kitsu there’s an issue for newly created shots (not sure I understood that right, but even more reason to make that a dedicated clear bug report)

  • Tray Publisher: Unclear how to define the handles for a plate that I’m dropping in for a shot. How can I in Tray Publisher say my plate has e.g. 12 frame handles at the start?

    • And maybe allow the frame range to be dropped in to also update the shot’s frame range? (separate request?)

Or @mustafa_jafar do you have a better idea to make these easier congestible issues that someone can easily provide clear answers to.

(As a reference, it took me just over two hours to go through your previous report with the video, all the bugs and respond to each of them and debug them. Preferably each of those would have been a bite-size issue I could’ve checked in isolation of each other.)

I manage to make it work for kitsu shots by changing naming template and now all metadata and file are here!!!

but errors still presist, do i just ignore them?

I’d say no - because failing in the Integrator can be very tricky to roll back and may have unexpected consequences - e.g. a version end up existing in the database, but the files not existing on disk.

In this case, it may be worth it doing a clean launch of Resolve, make the publish with the errors and copy over the full contents of Resolve’s console window to maybe allow some debugging based on ALL the logs of the publish itself. It’s unfortunate Resolve lags behind with the old publisher UI which doesn’t have the nice “Save to disk” button to share the full report.

Anyway, if you could make a new forum post about this - with the logs and maybe more details if you have any then that’d be great. Definitely something to look into at least.

Trying further learings where do i need to put files for editing? I thought that thought traypublisher but it seems that i cant paste a lot of movs to edit task

but with one file it works fine.

Looks like this is incorrect way to prodive files to editors. How it needs to be done?
Or if i need to place files by hand where i can click a button to generate folder structure?

If you want to add many plates, you add one plate. click create, then do the other. For most creators you’re creating a single product. If you want to batch ingest many files you may need to see if any of the ‘batch’ techniques work for you, that could be editorial, but maybe also the CSV ingest (likely to complex for your needs) but maybe the “batch movies” could work?

But, usually the creators works around creating a single instance. You’re looking to ingest many separate plates. Do they all need to be under one folder and task? Do they need to be per shot? etc. It seems like you just want to provide the editor with the clips. I’m personally not sure what Creators there are in Tray Publisher that would help with that. @libor.batek maybe?

A post was split to a new topic: Anatomy publish templatess

For batch MOV plates publishing you could also try Batch Movies


Unfortunatelly there is not yet done any documentation about the feature, but here are settings ayon+settings://traypublisher/create/BatchMovieCreator

1 Like

have no success using it, do i need to rename my movs? is it for edit?

as far as I know, it doesn’t work.