Ayon Launcher - missing dependencies

Hi guys!
I am no expert at this stuff but have followed the guides and managed to get Ayon server running, built Launcher successfully using git and the guides, and uploaded the installler (and .json file) to the server.
Have uploaded the integration zips to the server as well and created a bundle as recommended.

But when I try and run Launcher, I get an error saying “Dependancy package is missing or incompatible with available addons”

Have tried running ayon_console.exe - but get no other info regarding the error.

Any assistance with getting this resolved would be greatly appreciated.

I built both launcher 1.0.0-beta.5 and beta 6, but still get the error message.

Here’s where dependency packages settings,
Have you already set that setting ?

Hey there!
Thanks for the quick response .

I guess the issue here is - how do I create/find that dependency package?
I looked through the docs and readme files on github, but could not seem to find info on where that would be generated…

Ah - ok, I see there is a dependencies distribution tool - will look into that.

yep - you can use

1 Like

I’m experiencing the same error, but dependency package is assigned to bundle.
I ran ayon-dependencies-tool in Windows Sandbox successfully, and it uploaded a dependency package, which I assigned to a new Bundle.

When I ran Ayon Launcher, it then correctly gave me an “updating” prompt, and I can confirm it downloaded the dependency package to the appdata, next to the previous (default) dependency package.

Then I get the same error as described above.


Its hard to diagnose what is going wrong here…
Can you guys confirm that ayon-dependencies-tool is still working on your end?

can you share addon list with their versions you are using in that bundle?

We’re moving dependencies from ayon-launcher to OpenPype addon. There is a chance that you’ve hit incompatible versions of them, or you’ve used older version of dependencies tool.

I have the same issue, I pull the repo down, and it needs me create an .env file, which encompass AYON_API_KEY=
But I can’t find the api key, where to find it? Do I need to create an service user ?

yes, you’ll need to create a service user to obtain an AYON_API_KEY.

Just to be complete - if you’ve used Ayon docker and didn’t customize anything then the default ‘template settings’ it applies are defined in ayon-docker/settings/template.json which shows a default service user getting created:

            "name": "service",
            "apiKey": "veryinsecurapikey",
            "isService": true

As such, say you’re running a docker on localhost with those template settings then the Ayon Dependencies Tool .env would be: